Home
Join

4 Replies

  • Any user running SSMS on your computer also has a hidden C:\Users\<UserName>\AppData folder for the Microsoft apps (like SSMS) it runs.

    I would first try logging on to your computer with that domain\username - this should create the AppData folder if that user has permissions to logon to your computer.

    Then run SSMS (while logged on as domain\username).  This should create folders such as 'C:\Users\<username>\AppData\Local\Microsoft\SQL Server Management Studio' and 'C:\Users\<username>\Documents\SQL Server Management Studio' and also 'C:\Users\<username>\AppData\Local\VisualStudio' (amongst many others).

    If this works fine, then logoff, logon as your previous user, and then try to start SSMS with domain\username.

    Was this post helpful? thumb_up thumb_down
  • Thank you! Unfortunately, I cannot connect to the machine using the domain\usename

    Was this post helpful? thumb_up thumb_down
  • spicehead-fo8ca wrote:

    Thank you! Unfortunately, I cannot connect to the machine using the domain\usename

    That also means you cannot run SSMS on that same machine using domain\username .

    If you do not have any cross-domain permissions (to allow such logins), then you will need to run SSMS using your normal account on that computer, and then connect to the remote SQL server using a SQL account (not a Windows domain account).  Of course, the remote SQL server will need to be using 'SQL Server and Windows Authentication' mode.

    Pepper graySpice (1) flagReport
    Was this post helpful? thumb_up thumb_down
  • You cannot use runas to provide domain credentials for which the computer is not a part of the domain (or a trusted domain).

    Think of it this way - you're trying to make your computer run a program with the credentials of completely unknown, third-party entities.

    You must use a computer on the domain, or use SQL authentication (if that's allowed/enabled).

    Pepper graySpice (1) flagReport
    Was this post helpful? thumb_up thumb_down

Read these next...