Home
Join
check
  • 1.)  When you have OpenVPN - why do you than use Teamviewer? Once connected over OpenVPN use Remote Desktop

    2.) To be sure about Wake On Lan, you first need to test it locally on the network. Don't waste your time experimenting from remote, when it doesn't work locally.

    3.) Google says, that pfSense can send WakeOnLan packets to local computers. Test it while at home, so you will have it available when remotely.

    4.) Connect via OpenVPN and test your favorite WoL app. Possibly it will work and you won't have to 'kick' your computer from the pfSense box. However don't expect it will work, when it did not work when you were normally connected to the local network.

    5.) Leave Teamviewer just for cases, when OpenVPN doesn't work. It involves 3rd party networks and servers, so it's by definition less secure than a direct OpenVPN connection.

    1 found this helpful thumb_up thumb_down
  • View Best Answer in replies below

    4 Replies

    • 1.)  When you have OpenVPN - why do you than use Teamviewer? Once connected over OpenVPN use Remote Desktop

      2.) To be sure about Wake On Lan, you first need to test it locally on the network. Don't waste your time experimenting from remote, when it doesn't work locally.

      3.) Google says, that pfSense can send WakeOnLan packets to local computers. Test it while at home, so you will have it available when remotely.

      4.) Connect via OpenVPN and test your favorite WoL app. Possibly it will work and you won't have to 'kick' your computer from the pfSense box. However don't expect it will work, when it did not work when you were normally connected to the local network.

      5.) Leave Teamviewer just for cases, when OpenVPN doesn't work. It involves 3rd party networks and servers, so it's by definition less secure than a direct OpenVPN connection.

      1 found this helpful thumb_up thumb_down
    • Your method of using TeamViewer is fine, you just need to disable Sleep/Hibernate on the PC you're connecting to it seems, forget WoL.

      1 found this helpful thumb_up thumb_down
    • Bojan Zajc​ Thank you for the step by step. I appreciate it. I forgot about remote desktop honestly. I didnt think about testing locally since i figured the important thing is testing it not locally. Good points though I will test it locally then test it from a hotspot and see.

      bbigford​ thank you. ok i'll disable it and see. honestly I always leave it to hibernate/sleep so you mean just keep it on 24/7 straight so that way its always on (unless a power outage turns it off). ..which i figured always leaving your pc on all the time was bad? (either way i always keep mine on i just throw it in hibernate after a certain period of time.) I did just now set the computer to never sleep so hibernate should be off. I didnt know that having the PC in hibernate mode would affect the wol. Thank you for that info.

      Was this post helpful? thumb_up thumb_down
    • Bojan Zajc​ and bbigford​ I got it to work. I connected OpenVPN on my network on a laptop and then was able to connect via RDP. I tested internally and externally, both work great. thank you both.

      Spice (1) flagReport
      Was this post helpful? thumb_up thumb_down

    Read these next...