Default attachment size in Outlook Android App

KB5007409 - Exchange 2013 deaded after install
Get answers from your peers along with millions of IT pros who visit Spiceworks.
Join Now

I'm unable to send email from Outlook app ( android ) with attachment size 8 MB . Would like to know what's the default attachment size for Outlook app for ( ios and android ) . How can i increase the size . is it through Active Sync in IIS Portal ? 

Reference :  Configure client-specific message size limits | Microsoft Docs


lou1sl
Jalapeno
OP
lou1sl

Yes you could find the web.config file and change the values of the related keys:

https://docs.microsoft.com/en-us/exchange/architecture/client-access/client-message-size-limits?view...

The default size limit should be 10MB:

https://docs.microsoft.com/en-us/exchange/mail-flow/message-size-limits?view=exchserver-2019#server-...

But considering a 33% increasing of the messages size because of the encoding procress, the true limit should be about 7.5MB

For any message size limit, you need to set a value that's larger than the actual size you want enforced. This accounts for the Base64 encoding of attachments and other binary data. Base64 encoding increases the size of the message by approximately 33%, so the value you specify should be approximately 33% larger than the actual message size you want enforced. For example, if you specify a maximum message size value of 64 MB, you can expect a realistic maximum message size of approximately 48 MB.




Spiceworks Help Desk

The help desk software for IT. Free.

Track users' IT needs, easily, and with only the features you need.

4 Replies

· · ·
lou1sl
Jalapeno
OP
Best Answer
lou1sl

Yes you could find the web.config file and change the values of the related keys:

https://docs.microsoft.com/en-us/exchange/architecture/client-access/client-message-size-limits?view...

The default size limit should be 10MB:

https://docs.microsoft.com/en-us/exchange/mail-flow/message-size-limits?view=exchserver-2019#server-...

But considering a 33% increasing of the messages size because of the encoding procress, the true limit should be about 7.5MB

For any message size limit, you need to set a value that's larger than the actual size you want enforced. This accounts for the Base64 encoding of attachments and other binary data. Base64 encoding increases the size of the message by approximately 33%, so the value you specify should be approximately 33% larger than the actual message size you want enforced. For example, if you specify a maximum message size value of 64 MB, you can expect a realistic maximum message size of approximately 48 MB.




0
· · ·
lou1sl
Jalapeno
OP
lou1sl

Forgot to say that yes it is ActiveSync if you use Outlook for mobile devices.

If you want to manage the size limit for Outlook client for desktop, then you may refer to this document:

https://docs.microsoft.com/en-us/exchange/mail-flow/message-size-limits?view=exchserver-2019

0
· · ·
rafeeqahmed
Serrano
OP
rafeeqahmed This person is a Verified Professional
This person is a verified professional.
Verify your account to enable IT peers to see that you are a professional.

Lou1sl Thank you for the info, 

I want to increase the attachment size in the Mobile App from 10 MB to 20 MB ( 17.5 MB + 33% ). So the below changes would increase the capacity right ? 

Before Change:

Client Access (frontend)%ExchangeInstallPath%FrontEnd\HttpProxy\Sync\web.configmaxAllowedContentLength="30000000" (not present by default; see comments)bytes

ClientAccess(frontend)%ExchangeInstallPath%FrontEnd\HttpProxy\Sync\web.configmaxRequestLength="10240"kilobytes

Backend%ExchangeInstallPath%ClientAccess\Sync\web.configmaxAllowedContentLength="30000000 bytes" (not present by default; see comments)bytes

Backend%ExchangeInstallPath%ClientAccess\Sync\web.configmaxRequestLength="10240"kilobytes

Backend%ExchangeInstallPath%ClientAccess\Sync\web.config<add key="MaxDocumentDataSize" value="10240000">

Change to Increase to 20 MB : 

Client Access (frontend)%ExchangeInstallPath%FrontEnd\HttpProxy\Sync\web.configmaxAllowedContentLength="30000000" (not present by default; see comments)bytes

ClientAccess(frontend)%ExchangeInstallPath%FrontEnd\HttpProxy\Sync\web.configmaxRequestLength="2000"kilobytes

Backend%ExchangeInstallPath%ClientAccess\Sync\web.configmaxAllowedContentLength="30000000 bytes" (not present by default; see comments)bytes

Backend%ExchangeInstallPath%ClientAccess\Sync\web.configmaxRequestLength="2000"kilobytes

Backend%ExchangeInstallPath%ClientAccess\Sync\web.config<add key="MaxDocumentDataSize" value="21000000">


0
· · ·
lou1sl
Jalapeno
OP
lou1sl

Better:

maxRequestLength="20480"

maxRequestLength="20480"

MaxDocumentDataSize" value="20480000"

0
Oops, something's wrong below.